Re: Difference in luma-chroma delay of C64/C128 compared to standard S-video

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Difference in luma-chroma delay of C64/C128 compared to standard S-video

earth1dome1
Thanks for all of the info. Jeremy



Sent from my T-Mobile 4G LTE Device
-------- Original message --------
From: Mia Magnusson <[hidden email]>
Date: 9/3/2017 2:30 PM (GMT-08:00)
Subject: Re: Difference in luma-chroma delay of C64/C128 compared to standard S-video

I fired up my old CRT TV and also a supposedly good DVD player (Yamaha
DVD-S1700), and my C128.

Here are some pictures. I regret that I did't put in any text, just
bars. Also ideally it would have been better if I had ran some demo
code that changes background color on different parts of the screen, so
everey text colour could be seen with actual text on every background
color.

C128 on my CRT with perfect delay adjustment:
https://farm5.staticflickr.com/4341/36199895173_d6d220dd0e_o.jpg
https://flic.kr/p/X9RVDF

DVD on my CRT with perfect delay adjustment, different from C128:
https://farm5.staticflickr.com/4401/36199898253_46044f37f8_o.jpg
https://flic.kr/p/X9RWyM

C128 on my CRT but delay adjusted for perfect picture with DVD. Notice
white edge on the left of the yellow bar:
https://farm5.staticflickr.com/4392/36199901303_e6b8da65eb_o.jpg
https://flic.kr/p/X9RXtn C64 CRT but adjusted for DVD

DVD on my CRT but delay adjusted for perfect picture with C128. Notice
white edge on the right of the yellow "bars":
https://farm5.staticflickr.com/4365/36199904113_2e6e656df6_o.jpg
https://flic.kr/p/X9RYiP

This is how my C128 looks on my modern Samsung plasma. I assume the TV
set notices a delay and takes a bad guess how to adjust to the
situation, making it even worse:
https://farm5.staticflickr.com/4394/36199906213_a74e676c9d_o.jpg
https://flic.kr/p/X9RYW2 C64 on modern Plasma

This is how the DVD looks on my modern Samsung plasma. Good timing:
https://farm5.staticflickr.com/4434/36199907713_10141c4544_o.jpg
https://flic.kr/p/X9RZnT

The picture quality could probably be a bit better if I used better
cables to the CRT TV. As it only has one input (except RF) and since I
modified it for S-video myself all signals pass through a DB25 4-to-1
"computer cable switch" and back in the days I made cables with
DB25<->Scart and one of those cables has the chroma for S-video and
S-video/composite switch signal soldered directly to a cable in the TV
so I cannot change cables without doing some solder works. However
there isn't much ringing in the signal, just maybe a bit low luma
bandwith.


I'm not alone getting this timing error. Look at the pictures on this
blog:
https://ilesj.wordpress.com/2012/11/17/c64-s-video-cable-the-easy-way-and-with-no-scart/
and
https://ilesj.wordpress.com/2012/03/30/c64-av-cable-theory-and-practice/

(From the pictures we can assume that the combination of a C64/C128 and
a modern Samsung flat screen gives a far worse picture than most other
combinations, but if you look closely you will se a slight timing error
on most of the other pictures aswell).

Another blog with atleast one picture with severe timing error:
https://www.commodoreserver.com/BlogEntryView.asp?EID=F4B967500A894E10BE4A104C65DB541E
Look at the right (s-video) picture right below the text "Still a little
bleed on bright reds". The blue color starts about a pixel or two to
the right of the bright-to-dark luma transition to the left, and the
chroma for red color is about a pixel or two to the right of the luma
in the C in the upper right corner.

If you click on the picture here and zoom in to 1:1 pixel ratio, you
will obviously see that the red chroma is a fair bit to the right of
the corresponding luma:
http://www.retro-programming.de/retro-welt-2/hardware/lotkolben/c64-s-videokabel/

It's also slightly visible on this picture, showing the difference
between stock C64 and C64 with modified analogue buffers in the RF
modulator:
http://oms.wmhost.com/modulator_vs_spider.png

P.S. here is a picture where someone has modified their VIC-20 for
S-video and gets incorrect timing but the other way around, chroma
before luma:
http://sleepingelephant.com/ipw-web/bulletin/bb/viewtopic.php?t=2477&start=105



--
(\_/) Copy the bunny to your mails to help
(O.o) him achieve world domination.
(> <) Come join the dark side.
/_|_\ We have cookies.

       Message was sent through the cbm-hackers mailing list