1541II and 1571 repair (fwd)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

1541II and 1571 repair (fwd)

Marko Mäkelä-2
Hola Domingo,

I'm forwarding your message to the cbm-hackers mailing list in the hope
that someone there can help you.  I don't have either drive myself.
The problems could be with the power supply (measure the voltages while
the power supply is connected to the drive and the drive is switched on),
e.g. in the rectifier bridge (four diodes).  Or something (e.g. one of the
6522 VIAs) could be broken.

If you haven't found Raymond Carlsen's repair tips yet, you could perhaps
find some help there: <URL:http://www.funet.fi/pub/cbm/documents/repair/>.
There are no specific instructions for the 1541-II and the 1571 there,
though.  But the 1541 should be quite similar to the 1571.

        Marko

---------- Forwarded message ----------
Date: Mon, 15 Mar 1999 20:58:31 -0500 (EST)
From: [hidden email]
To: [hidden email]
Subject: 1541II and 1571 repair

   

   Hello Marko!

   Here is another commodore 64 friend from Spain.
   I write this Email because i need help to repair my
disks drive... and i think that you have the info...
   Really great web page from you friend... well about
my problems with drives:
   
   1571 disk drive, when the drive powered up red led
stay on and motor run continuously and green led stay
off.

   1541 II disk drive, when the drive powered up red
led stay off and green led stay off and motor run
continuously.

   What about that problems? please send me a
Diagnostics.

   thanxs in advance... your friend Domingo...

   Send as soon as possible.Email: [hidden email]






----------------------------------------------------------------
Get your free email from AltaVista at http://altavista.iname.com

-
This message was sent through the cbm-hackers mailing list.
To unsubscribe: echo unsubscribe | mail [hidden email].

Reply | Threaded
Open this post in threaded view
|

Re: 1541II and 1571 repair (fwd)

Pasi Ojala
>    1571 disk drive, when the drive powered up red led
> stay on and motor run continuously and green led stay
> off.
>
>    1541 II disk drive, when the drive powered up red
> led stay off and green led stay off and motor run
> continuously.

It could be one of the TTL chips in the reset circuit
UD3 (74LS86) or maybe UA1 (74LS14) or UB1 (74LS06).
Measure the reset signal to see if it goes high after powerup.
If it doesn't, it's probably one of these chips.

I repaired two drives this way a couple of years back.

-Pasi
--
"Lyta Alexander. She was the first commercial telepath assigned to
 Babylon 5 little over two years ago. She arrived January 3, 2257.
 She left about six weeks later."
        -- Garibaldi to Sheridan in Babylon 5:"Divided Loyalties"
-
This message was sent through the cbm-hackers mailing list.
To unsubscribe: echo unsubscribe | mail [hidden email].

Reply | Threaded
Open this post in threaded view
|

Re: 1541II and 1571 repair (fwd)

g.j.p.a.a.baltissen
In reply to this post by Marko Mäkelä-2
Hallo Domingo,

I repaired several drives last few months and they had all troubles with either
the the 74LS14, most likely blown up by static electricity, and the the 5 Volt
rectifier. The last one I always replace by a 3A type.
The above agrees with Pasi's experiences.

Groetjes, Ruud


-
This message was sent through the cbm-hackers mailing list.
To unsubscribe: echo unsubscribe | mail [hidden email].